Client Side

Operating Systems

  • Windows XP/Vista/7 (including East Asian editions)
  • MacOS 10.5 or later
  • *NIX systems with Sun Java Runtime Environment

Browsers

  • Internet Explorer (Windows) 6 or later. ActiveX controls and JavaScript should be enabled in the browser settings.
  • A browser which supports Java applets with Sun JRE 1.5:

    • Any Mozilla-family browser, including Firefox 2 or later, Netscape, and others
    • Safari (Mac)
    • Google Chrome

    LiveConnect availability (required for some advanced features such as an additional form name uploading, event handling, etc).

    Java applets and JavaScript should be enabled in the browser settings.

Note

Some Mac browsers require Java Embedding Plug-in to be JRE 1.5-compatible.

These browsers do not require this plug-in:

  • Safari
  • Firefox version 2.0 or later

The following browsers are not supported:

  • Internet Explorer for Mac (no JRE 1.5 compatibility)
  • Opera

Server Side

To sucessfully use Image Uploader you must have a fully operational web server (for example, Apache or IIS).

Image Uploader ASP.NET and Image Uploader PHP have the following additional server-side requirements:

Image Uploader ASP.NET

  • Microsoft Visual Studio 2005/2008/2010
  • .NET Framework 2.0, 3.x, 4.0
Note

Image Uploader ASP.NET does not support .NET Framework 1.1.

Image Uploader PHP

  • PHP 5 (5.2 or higher) / PHP 6